LogoLogo
  • RouterOS Scripts
  • Scripts
    • Forward log messages via notification
    • Mode button with multiple presses
    • Import SSH keys
    • Act on received SMS
    • Install LTE firmware upgrade
    • Visualize OSPF state via LEDs
    • Use wireless network with daily psk
    • Find and remove access list duplicates
    • Create DNS records for DHCP leases
    • Manage remote logging
    • Forward received SMS
    • Collect MAC addresses in wireless access list
    • Notify about health state
    • Update configuration on IPv6 prefix change
    • Renew certificates and notify on expiration
    • Renew locally issued certificates
    • Upload backup to server
    • Play Super Mario theme
    • Manage IP addresses with bridge status
    • Notify on LTE firmware upgrade
    • Run scripts on ppp connection
    • Run other scripts on DHCP lease
    • Update GRE configuration with dynamic addresses
    • Manage system update
    • Manage LEDs dark mode
    • Upload backup to Mikrotik cloud
    • Send GPS position to server
    • Rotate NTP servers
    • Manage ports in bridge
    • Update tunnelbroker configuration
    • Notify on host up and down
    • Notify on RouterOS update
    • Send notification with early errors
    • Use WPA2 network with hotspot credentials
    • Send backup via e-mail
    • Run rolling CAP upgrades from CAPsMAN
    • Wait for configuration und functions
    • Download packages for CAP upgrade from CAPsMAN
    • Comment DHCP leases with info from access list
  • Initial commands
  • COPYING
Powered by GitBook
On this page
  • Description
  • Requirements and installation
  • Configuration
  • Usage and invocation

Was this helpful?

  1. Scripts

Mode button with multiple presses

PreviousForward log messages via notificationNextImport SSH keys

Last updated 4 years ago

Was this helpful?

Description

This script extend the functionality of mode button. Instead of just one you can trigger several actions by pressing the mode button several times.

The hardware needs to have a mode button, see / system routerboard mode-button. Starting with RouterOS 6.47beta60 you can configure the reset button to act the same, see / system routerboard reset-button.

Copy this code to terminal to check:

:if ([ :len [ /system routerboard mode-button print as-value ] ] > 0) do={
  :put "Mode button is supported.";
} else={
  :if ([ :len [ /system routerboard reset-button print as-value ] ] > 0) do={
    :put "Mode button is not supported, but reset button is.";
  } else={
    :put "Neither mode button nor reset button is supported.";
  }
}

Requirements and installation

Just install the script:

$ScriptInstallUpdate mode-button;

Then configure the mode button to run mode-button:

/ system routerboard mode-button set enabled=yes on-event="/ system script run mode-button;";

To use the reset button instead:

/ system routerboard reset-button set enabled=yes on-event="/ system script run mode-button;";

Configuration

The configuration goes to global-config-overlay, these are the parameters:

  • ModeButton: an array with defined actions

  • ModeButtonLED: led to give visual feedback

Usage and invocation

Press the mode button. :)

◀ Go back to main README
◀ Go back to main README
▲ Go back to top